Degraded Console Service
Incident Report for JumpCloud
Resolved
This incident is now considered resolved. At this time, new JumpCloud agent installs should process successfully and all services related to https://console.jumpcloud.com/ and the JumpCloud Agent should be fully operational.

Our database layer experienced an unexpected consumption at a rate that significantly impacted the database replicas. The recovery process impacted normal database operation that serves our User and Admin Portals. To reduce load, our engineers temporarily paused background work related to the JumpCloud Agent, allowing the primary and backup databases to fully recover. Our engineers then restored background processing and our systems processed the work that was queued during the primary outage.
Posted Oct 14, 2021 - 17:17 MDT
Monitoring
A fix has been implemented across all JumpCloud Agent services and https://console.jumpcloud.com/. New Agent installs should now complete successfully. Updates made via JumpCloud's Agent throughout the duration of the incident will eventually process without the need of additional admin intervention.

We are continuing to monitor the fix and will post again once the issue is considered fully resolved.
Posted Oct 14, 2021 - 16:27 MDT
Update
We are seeing reports of JumpCloud Agents now checking in intermediately. We are actively working on a solution to fully restore service to the JumpCloud Agent. During this time, new agent installs may fail and changes made via an existing JumpCloud managed device will be delayed. Updates made via JumpCloud's Agent will eventually process without the need of additional admin intervention.
Posted Oct 14, 2021 - 16:09 MDT
Update
Service to the JumpCloud User and Admin Portal at https://console.jumpcloud.com/ should now be restored and operational.

We are actively working on a solution to restore service to the JumpCloud Agent. During this time, new agent installs will fail and changes made via an existing JumpCloud managed device will be delayed. Updates made via JumpCloud's Agent will eventually process without the need of additional admin intervention.
Posted Oct 14, 2021 - 15:31 MDT
Update
Service to the JumpCloud User and Admin Portal at https://console.jumpcloud.com/ should now be restored and operational.

We are actively working on a solution to restore service to the JumpCloud Agent. During this time, new agent installs will fail and changes made via an existing JumpCloud managed device will be delayed. Updates made via JumpCloud's Agent will eventually process without the need of additional admin intervention.
Posted Oct 14, 2021 - 15:08 MDT
Update
We are seeing reports of degraded performance or intermittent connectivity issues with the JumpCloud User Portal and Admin Console at https://console.jumpcloud.com/. We are working on a fix to stabilize https://console.jumpcloud.com/

Additionally, we are actively working on a solution to restore service to the JumpCloud Agent. During this time, new agent installs will fail and changes made via an existing JumpCloud managed device will be delayed. Updates made via JumpCloud's Agent will eventually process without the need of additional admin intervention.
Posted Oct 14, 2021 - 14:41 MDT
Update
We are seeing new reports of degraded performance or intermittent connectivity issues with the JumpCloud User Portal and Admin Console at https://console.jumpcloud.com/.

Additionally, we are actively working on a solution to restore service to the JumpCloud Agent. During this time, new agent installs will fail and changes made via an existing JumpCloud managed device will be delayed. Updates made via JumpCloud's Agent will eventually process without the need of additional admin intervention.
Posted Oct 14, 2021 - 14:06 MDT
Update
We are actively working on a solution to restore service to the JumpCloud Agent. We are still seeing degraded services with the JumpCloud Agent. During this time, new agent installs and changes made via an existing JumpCloud managed device will be delayed. Updates made via JumpCloud's Agent will eventually process without the need of additional admin intervention.

Service to JumpCloud's User Portal, Admin Portal, Single Sign On (SSO), and RADIUS should now be restored. Users should be able to successfully authenticate and utilize those services at this time.

We will provide another update in 20 minutes or before that time when we have additional information.
Posted Oct 14, 2021 - 13:35 MDT
Update
We are actively working on a solution to restore service to the JumpCloud Agent. We are still seeing degraded services with the JumpCloud Agent. During this time, new agent installs and changes made via an existing JumpCloud managed device will be delayed. Updates made via JumpCloud's Agent will eventually process without the need of additional admin intervention.

Service to JumpCloud's User Portal, Admin Portal, Single Sign On (SSO), and RADIUS should now be restored. Users should be able to successfully authenticate and utilize those services at this time.

We will provide another update in 20 minutes or before that time when we have additional information.
Posted Oct 14, 2021 - 13:14 MDT
Update
We are actively working on a solution to restore service to the JumpCloud Agent. We are still seeing degraded services with the JumpCloud Agent. During this time, new agent installs and changes made via an existing JumpCloud managed device will be delayed. Updates made via JumpCloud's Agent will eventually process without the need of additional admin intervention.

Service to JumpCloud's User Portal, Admin Portal, Single Sign On (SSO), and RADIUS should now be restored. Users should be able to successfully authenticate and utilize those services at this time.

We will provide another update in 20 minutes or before that time when we have additional information.
Posted Oct 14, 2021 - 12:52 MDT
Update
We are actively working on a solution to restore service to the JumpCloud Agent. We are still seeing degraded services with the JumpCloud Agent. During this time, new agent installs and changes made via an existing JumpCloud managed device will be delayed. Updates made via JumpCloud's Agent will eventually process without the need of additional admin intervention.

Service to JumpCloud's User Portal, Admin Portal, Single Sign On (SSO), and RADIUS should now be restored. Users should be able to successfully authenticate and utilize those services at this time.

We will provide another update in 20 minutes or before that time when we have additional information.
Posted Oct 14, 2021 - 12:27 MDT
Update
We are actively working on a solution to restore service to JumpCloud's Agent. We are still seeing degraded services with JumpCloud's Agent. During this time, new agent installs and changes made via an existing JumpCloud managed device will be delayed. Updates made via JumpCloud's Agent will eventually process without the need of additional admin intervention.

Service to JumpCloud's User Portal, Admin Portal, Single Sign On (SSO), and RADIUS should now be restored. Users should be able to successfully authenticate and utilize those services at this time.

We will provide another update in 20 minutes or before that time when we have additional information.
Posted Oct 14, 2021 - 12:00 MDT
Update
Service to JumpCloud's User Portal, Admin Portal, Single Sign On (SSO), and RADIUS should now be restored. Users should be able to successfully authenticate and utilize those services at this time.

We are still seeing degraded services with JumpCloud's Agent. During this time, new agent installs and changes made via an existing JumpCloud managed device will be delayed. Updates made via JumpCloud's Agent will eventually process without the need of additional admin intervention.

We will provide another update in 20 minutes or before that time when we have additional information.
Posted Oct 14, 2021 - 11:08 MDT
Identified
The issue has been identified and a fix is being implemented. We are starting to see successful authentication attempts to the JumpCloud User and Admin portals at https://console.jumpcloud.com/. We will continue to monitor and work on a comprehensive resolution until all services are restored.

We will provide another update in 20 minutes or before that time when we have additional information.
Posted Oct 14, 2021 - 10:43 MDT
Update
We are continuing to investigate reports of degraded performance or intermittent connectivity issues with the JumpCloud Console at https://console.jumpcloud.com/. Multiple services are impacted at this time.

SAML authentication that requires JumpCloud User Portal access may continue to be impacted and MFA enabled users may have difficulty accessing RADIUS. Non-MFA users should not be experiencing issues with JumpCloud’s RADIUS service at this time.

API calls to JumpCloud endpoints may timeout during this time.

The JumpCloud Agent may be failing to check in intermediately, which may temporarily impact new agent installs.

We are investigating the cause of the issues currently, and will update the status event once resolved.

We will provide another update in 20 minutes or before that time when we have additional information.
Posted Oct 14, 2021 - 09:42 MDT
Update
We are continuing to investigate reports of degraded performance or intermittent connectivity issues with the JumpCloud Console at https://console.jumpcloud.com/. Multiple services are impacted at this time.

SAML authentication that requires JumpCloud User Portal access may continue to be impacted and MFA enabled users may have difficulty accessing RADIUS. Non-MFA users should not be experiencing issues with JumpCloud’s RADIUS service at this time.

API calls to JumpCloud endpoints may timeout during this time.

The JumpCloud Agent may be failing to check in intermediately, which may temporarily impact new agent installs.

We are investigating the cause of the issues currently, and will update the status event once resolved.

We will provide another update in 20 minutes or before that time when we have additional information.
Posted Oct 14, 2021 - 09:19 MDT
Update
We are continuing to investigate reports of degraded performance or intermittent connectivity issues with the JumpCloud Console at https://console.jumpcloud.com/.

SAML authentication that requires JumpCloud User Portal access may continue to be impacted and MFA enabled users may have difficulty accessing RADIUS. Non-MFA users should not be experiencing issues with JumpCloud’s RADIUS service at this time. We are investigating the cause of the issues currently, and will update the status event once resolved.

We will provide another update in 20 minutes or before that time when we have additional information.
Posted Oct 14, 2021 - 08:47 MDT
Update
We are continuing to investigate reports of degraded performance or intermittent connectivity issues with the JumpCloud Console at https://console.jumpcloud.com/.

SAML authentication that requires JumpCloud User Portal access may continue to be impacted and MFA enabled users may have difficulty accessing RADIUS. Non-MFA users should not be experiencing issues with JumpCloud’s RADIUS service at this time. We are investigating the cause of the issues currently, and will update the status event once resolved.
Posted Oct 14, 2021 - 08:06 MDT
Update
We are continuing to investigate this issue.
Posted Oct 14, 2021 - 07:17 MDT
Update
We’re currently investigating reports of degraded performance or intermittent connectivity issues with the JumpCloud Console at https://console.jumpcloud.com/.

In addition, we are investigating reports that MFA enabled users are experiencing issues accessing RADIUS. Non-MFA users should not be experiencing issues with JumpCloud’s RADIUS service at this time. We are investigating the cause of the issues currently, and will update the status event once resolved.
Posted Oct 14, 2021 - 07:14 MDT
Investigating
We’re currently investigating reports of degraded performance or intermittent connectivity issues with the JumpCloud Console at https://console.jumpcloud.com/.

In addition, we are investigating reports that MFA enabled users are experiencing issues accessing RADIUS. Non-MFA users should not be experiencing issues with JumpCloud’s RADIUS service at this time. We are investigating the cause of the issues currently, and will update the status event once resolved.
Posted Oct 14, 2021 - 06:28 MDT
This incident affected: Admin Console, Agent, General Access API, RADIUS, SSO, and User Console.