SendGrid SMTP Services
Incident Report for JumpCloud
Resolved
This incident has been resolved.
Posted Feb 19, 2020 - 20:02 MST
Identified
SendGrid has confirmed that new mail received is being processed and delivery is attempted as normal. They are currently working to dequeue the subset of mail that was delayed between approximately 4:30 pm MT and 5:00 pm MT. We will continue to update as that mail dequeues.
Posted Feb 19, 2020 - 18:35 MST
Update
We are continuing to investigate this issue.
Posted Feb 19, 2020 - 18:34 MST
Investigating
JumpCloud's email service provider is investigating reports of delivery delays, beginning at approximately 16:30 MT. This could impact receipt of emails related to Password Resets and New Account Creation. We will relay updates from SendGrid as they become available.
Posted Feb 19, 2020 - 18:30 MST
This incident affected: SendGrid SMTP Services.