Admin Console Performance issue
Incident Report for JumpCloud
Resolved
This incident has been resolved.
Posted Feb 09, 2024 - 08:19 MST
Monitoring
The issue was identified, a fix implemented and we are now monitoring.
Posted Feb 09, 2024 - 07:58 MST
Investigating
We are experiencing performance issues when navigating the Admin console. This is under investigation.
Posted Feb 09, 2024 - 06:12 MST
This incident affected: Admin Console.