Degraded Admin Console Service

Incident Report for JumpCloud

Resolved

This incident has been resolved.
Posted May 14, 2025 - 11:48 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 10:24 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 14, 2025 - 08:47 MDT

Investigating

We're currently investigating an issue with JumpCloud's Console where Administrators may be unable to save changes for some device records. We are investigating the cause of the issues currently, and will update the status event once resolved.
Posted May 14, 2025 - 08:22 MDT
This incident affected: Admin Console.