Password Manager Degraded Service
Incident Report for JumpCloud
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 07:23 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2024 - 06:56 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 08, 2024 - 05:50 MST
Investigating
We're currently investigating high error rates with Password Manager while accessing the Admin console and the failure to load overview details. This will also prevent Admins from being removed (deleted) from the Admin Portal.
Posted Mar 08, 2024 - 05:31 MST
This incident affected: Admin Console.