Reporting Data Delay

Incident Report for JumpCloud

Resolved

This incident has been resolved. Reports data is now fully up to date.
Posted Sep 04, 2025 - 15:34 MDT

Update

We are still monitoring the progress in updating the stale data. We will continue to provide regular communication. Please expect the another update within the next two hours.
Posted Sep 04, 2025 - 13:21 MDT

Monitoring

A fix has been implemented and we are currently monitoring the progress in updating the stale data. We will provide further updates in the next two hours.
Posted Sep 04, 2025 - 11:24 MDT

Update

We are still working on this issue. We are monitoring the reduction in stale data and will provide a further update in the next few hours.
Posted Sep 04, 2025 - 08:47 MDT

Identified

We are seeing issues with stale data on reports in JumpCloud. We have deployed the relevant fix and will continue to monitor this issue. Please note that data in reports is only affected and all other data is correct. We will update within 1 hour.
Posted Sep 04, 2025 - 07:14 MDT
This incident affected: Reporting.