Dynamic Group Delays

Incident Report for JumpCloud

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 06:22 MDT

Update

We are continuing to monitor for any further issues.
Posted Sep 03, 2026 - 04:54 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2026 - 04:05 MDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2026 - 02:56 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 03, 2026 - 00:14 MDT

Investigating

JumpCloud is currently experiencing delays in assigning Users and Systems to Dynamic Groups. Administrators may see delays in these Group membership updates, and thus delays in provisioning to connected resources.
Posted Sep 03, 2026 - 00:07 MDT
This incident affected: Groups (user/devices) (Groups (user/devices) - US Region).