Degraded Agent Service on MacOS, Windows and Linux

Incident Report for JumpCloud

Resolved

The incident has been resolved.
Posted Apr 28, 2026 - 03:55 MDT

Monitoring

A fix has been implemented, and Agent installations should now be functioning as expected. Our team is actively monitoring the situation to ensure continued stability.
Posted Apr 28, 2026 - 03:00 MDT

Identified

The issue has been identified and a fix will be implemented soon.
Posted Apr 28, 2026 - 02:57 MDT

Investigating

We are currently aware of reports with agent Installation failing, this is affecting MacOS, Windows and Linux. We are investigating the cause of the issues currently, and will provide an update within one hour.
Posted Apr 28, 2026 - 02:01 MDT
This incident affected: Agent (Agent).