Degraded JumpCloud Premium Chat

Incident Report for JumpCloud

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 08:42 MST

Investigating

We are currently experiencing issues with the JumpCloud Premium Support Chat function. Customers are able to submit tickets via the Admin Console. Instructions for submitting tickets via the Admin Console can be found here: https://jumpcloud.com/support/contact-jumpcloud-support#submitting-a-support-ticket-from-the-admin-portal
Posted Feb 25, 2025 - 08:15 MST