Degraded Console Service

Incident Report for JumpCloud

Resolved

All operations have returned to normal and the issue is currently considered resolved.
Posted Jul 29, 2025 - 02:38 MDT

Monitoring

The issue has been identified and a fix has been implemented. We are now monitoring the results. The Admin Portal is fully operational now.
Posted Jul 29, 2025 - 02:25 MDT

Investigating

We're currently investigating reports of usability issues with JumpCloud's Admin Portal. We are investigating the cause of the issues currently, and will update the status once resolved.
Posted Jul 29, 2025 - 01:50 MDT
This incident affected: Admin Console.