Degraded Support Portal Service

Incident Report for JumpCloud

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 00:19 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2025 - 00:10 MDT

Investigating

We are currently investigating intermittent reports of Administrators being unable to submit support cases via the JumpCloud Admin Portal. Support cases can still be submitted by emailing support@jumpcloud.com. We are investigating the cause of the issues currently, and will update the status event once resolved.
Posted Jun 09, 2025 - 23:56 MDT
This incident affected: Support Services (Email Support).