Degraded Agent Service - macOS
Incident Report for JumpCloud
Postmortem

At approximately 15:35 UTC on Wednesday, July 14th JumpCloud identified an issue with the 0.179.3 macOS Agent.  After receiving reports of a macOS login window issue that prevented users from completing their macOS login, the JumpCloud Agent deployment was stopped immediately.   Agent version 0.179.3 was deployed to a small subset of macOS devices. Windows and Linux devices were not impacted. 

‌ This issue was not a security breach. It was related to an internal JumpCloud agent build issue and a full root cause analysis is underway. A fix was implemented for the issue at 3:08 UTC on Thursday, July 15th and the issue is considered resolved as of that time.

Posted Jul 15, 2021 - 13:15 MDT

Resolved
We've deployed a fix to production and our testing shows this fix to be successful.
Posted Jul 14, 2021 - 21:08 MDT
Update
We have tested the fix and are in the process of deploying this to production. We will post an update when that is complete.
Posted Jul 14, 2021 - 20:14 MDT
Update
We are currently in the process of testing the fix locally before deployment. We will update again when the fixed is pushed to production.
Posted Jul 14, 2021 - 17:23 MDT
Update
We are continuing to work on a fix and will provide another update in 30 minutes or less.
Posted Jul 14, 2021 - 16:51 MDT
Identified
The issue has been identified and we are working on a fix. We will provide another update when a fix has been implemented.
Posted Jul 14, 2021 - 16:15 MDT
Update
We continue to investigate this issue and are testing possible solutions. We will post another update as we know more.
Posted Jul 14, 2021 - 15:19 MDT
Update
We are still investigating this issue and will provide another update in 30 minutes, or as soon as we know more.
Posted Jul 14, 2021 - 14:43 MDT
Investigating
We're currently investigating an issue with the JumpCloud macOS agent. Users in some circumstances are unable to access the login window on macOS devices. We are actively working on this issue as our highest priority.
Posted Jul 14, 2021 - 14:08 MDT
This incident affected: Agent.