Console Degradation - Cloudflare Network Disruption

Incident Report for JumpCloud

Resolved

The third party issue impacting our service has been resolved. Our internal monitoring is showing service states returned to normal.
Posted Jun 22, 2026 - 10:39 MDT

Identified

We have identified that a third party outage is impacting our service. More information can be found at https://www.cloudflarestatus.com/incidents/v3yl7jqmqj51
Posted Jun 22, 2026 - 09:08 MDT

Investigating

We are currently investigating delays or timeouts loading the user console. We are investigating the cause of the issues currently, and will provide an update within one hour.
Posted Jun 22, 2026 - 08:21 MDT
This incident affected: User Console (User Console - US Region).