G Suite and Office 365 Activation/Reactivation
Incident Report for JumpCloud
Resolved
This incident has been resolved. Please contact support@jumpcloud.com if you have any questions or further issues.
Posted 3 months ago. May 22, 2019 - 10:48 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. May 22, 2019 - 10:18 MDT
Investigating
We are investigating reports of administrators stating they are unable to create and save G-Suite or Office 365 instances.
Posted 3 months ago. May 22, 2019 - 08:45 MDT
This incident affected: G Suite Integration and Office 365 Integration.