Admin Console and MDM Service Impacted
Incident Report for JumpCloud
Postmortem

JumpCloud Incident Report

Date: 2022-10-11

Date of Incident: 2022-10-03

Description: RCA for JumpCloud Admin Console, and MDM Service Interruption

Summary:

At approximately 11:50 MDT on 2022-10-03, JumpCloud Administrators encountered a ‘Loading Error’ when attempting to access the Admin console.  Additionally, any new MDM device enrollments failed to complete.  This incident lasted until approximately 15:30 MDT on 2022-10-03.

Root Cause:

The incident was caused by an upgrade to our Object Data Modeling (ODM) library, which created read errors for both role based access control and versioning data required to enroll new devices into MDM. We rolled back the ODM update and executed our recovery procedures which restored access to the Admin Console, and the ability to enroll devices into MDM.

Corrective Actions / Risk Mitigation:

  • Expanded test plan around ODM library changes - Target 10.2022
  • Re-review recovery plans for gaps or inefficiencies - In Progress
  • Modify behavior on datasets for compatibility with required ODM library - Done
Posted Oct 11, 2022 - 10:09 MDT

Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 16:14 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2022 - 15:33 MDT
Update
We are in the process of completing an update to restore functionality to a few of JumpCloud's core services related to the Admin Console and MDM. We've observed progress in the restoration of these services and will post another update once complete.
Posted Oct 03, 2022 - 14:55 MDT
Update
Our teams are continuing to work on implementing a fix for the issues impacting JumpCloud Admin Console and MDM Enrollments. We will provide another update when we have more information or when the fix is complete.
Posted Oct 03, 2022 - 14:05 MDT
Update
As part of the ongoing issue with the JumpCloud Admin Console new MDM enrollments are impacted as well. We will continue to post updates for the JumpCloud Admin Console and MDM Enrollments until these issues are resolved.
Posted Oct 03, 2022 - 13:30 MDT
Update
We are continuing to work on implementing a fix for the JumpCloud Admin Console. The JumpCloud User Console is fully functional and end users should be able to continue to access SSO Applications from the User Console via https://console.jumpcloud.com/userconsole#/
Posted Oct 03, 2022 - 13:20 MDT
Identified
The issue has been identified and we are working on implementing a fix.
Posted Oct 03, 2022 - 12:42 MDT
Investigating
We are currently investigation an increase in error rates logging into the Admin Portal. We will update as soon as we know more.
Posted Oct 03, 2022 - 11:53 MDT
This incident affected: Admin Console and MDM.