Degraded Console Service - Devices Page slowness

Incident Report for JumpCloud

Resolved

This incident has been resolved.
Posted May 08, 2026 - 02:28 MDT

Monitoring

A fix has been implemented. We are currently monitoring the results.
Posted May 08, 2026 - 00:51 MDT

Identified

The issue has been identified and the team is working on the fix.
Posted May 08, 2026 - 00:44 MDT

Investigating

We are currently investigating delays or timeouts loading the devices page in the admin console. We are investigating the cause of the issues currently, and will provide an update within one hour.
Posted May 08, 2026 - 00:41 MDT
This incident affected: Admin Console (Admin Console).