Degraded Website
Incident Report for JumpCloud
Resolved
This incident has been resolved.
Posted Oct 22, 2024 - 17:42 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 22, 2024 - 17:33 MDT
Investigating
We're currently investigating reports of degraded performance or intermittent connection issues on jumpcloud.com. We are investigating the cause of the issues currently, and will update the status event once resolved. Note that the JumpCloud Admin Console & User Portal are operational.
Posted Oct 22, 2024 - 17:20 MDT
This incident affected: Support Services (jumpcloud.com/support) and www.jumpcloud.com.