Password Manager Chrome Extension
Incident Report for JumpCloud
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 17:51 MDT
Monitoring
We've released a new version (v2.0.12.1) of the Password Manager Chrome Extension which should download shortly. If it doesn't happen automatically, customers can prompt updates by going to chrome://extensions, hitting "Developer Mode", and hitting the "Update" button.
Posted Sep 27, 2024 - 17:33 MDT
Investigating
The latest Chrome update may be conflicting with the JumpCloud Password Manager Chrome Extension on certain websites. If you are experiencing performance issues with Chrome, you may need to disable the Password Manager Chrome Extension, use Chrome in incognito mode, or use another browser until we are able to provide a solution for this issue. We are working on a fix and will provide an update as soon as possible.
Posted Sep 27, 2024 - 15:24 MDT
This incident affected: Password Manager.