Display issue for Filevault recovery keys

Incident Report for JumpCloud

Postmortem

JumpCloud Incident Report

Date: 2022-07-17

Date of Incident: 2022-07-06

Description: RCA for FileVault recovery key display failure

Summary:

At approximately 12:15 MDT on 2022-07-06, some JumpCloud customers experienced failures in viewing and accessing FileVault recovery keys for macOS devices.   This lasted until approximately 17:00 MDT on 2022-07-06.

Root Cause:

A code deploy intended to hide non-MDM devices from the VPP software display inadvertently caused a problem with displaying FileVault recovery keys for macOS devices.  ‌

Corrective Actions / Risk Mitigation:

  • Roll back failed version - DONE
  • Increased hardening of the MDM integration - Target 07/2022
  • Update framework around the Systems display modal - Target 08/2022
  • Additional alerting on these components - Target 07/2022
Posted Jul 17, 2022 - 12:25 MDT

Resolved

This incident has been resolved.
Posted Jul 06, 2022 - 17:45 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2022 - 17:23 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 06, 2022 - 17:19 MDT

Investigating

We are investigating a potential issue with properly displaying Filevault recovery key information for macOS systems. We will report back as soon as we have an update. We apologize for any disruption this may cause.
Posted Jul 06, 2022 - 16:59 MDT
This incident affected: Admin Console.