JumpCloud University

Incident Report for JumpCloud

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 12:45 MDT

Identified

university.jumpcloud.com is still under maintenance, and we are currently working with our third party vendor on implementing a fix to resolve the outstanding issues with the migration.
Posted Jul 15, 2025 - 11:06 MDT
This incident affected: JumpCloud University.