User Console / JumpCloud Protect Degraded Service - AWS 3rd Party Issue
Incident Report for JumpCloud
Resolved
At this time, we are comfortable with the testing completed for JumpCloud Protect. AWS has only moderate issues remaining, and that status can be found at:
https://status.aws.amazon.com/

We appreciate your patience while AWS worked to get their services back online. At this time we are marking this resolved.
Posted Dec 07, 2021 - 18:10 MST
Monitoring
At this time we believe AWS has restored service to the components needed for JumpCloud Protect to operate correctly. However, we continue to monitor at this time and will resolve this issue shortly, after we complete some additional testing.
Posted Dec 07, 2021 - 17:17 MST
Update
We are seeing some slowness with JumpCloud Protect, but less failures at this time. AWS appears to have made some progress and released the following:

"We have executed a mitigation which is showing significant recovery in the US-EAST-1 Region. We are continuing to closely monitor the health of the network devices and we expect to continue to make progress towards full recovery. We still do not have an ETA for full recovery at this time."

We will continue to monitor and update this page as we learn more.
Posted Dec 07, 2021 - 15:25 MST
Update
We continue to monitor the AWS situation, but still expect intermittent failures using JumpCloud Push. We will continue to update this page as we learn more. A full update from AWS can be found at https://status.aws.amazon.com/
Posted Dec 07, 2021 - 14:17 MST
Update
AWS is seeing signs of improvement, but we are still monitoring as JumpCloud Push is only intermittently working. We will update you as we learn more. Latest message from AWS, which can be found at https://status.aws.amazon.com/:

We are seeing impact to multiple AWS APIs in the US-EAST-1 Region. This issue is also affecting some of our monitoring and incident response tooling, which is delaying our ability to provide updates. We have identified root cause of the issue causing service API and console issues in the US-EAST-1 Region, and are starting to see some signs of recovery. We do not have an ETA for full recovery at this time.
Posted Dec 07, 2021 - 12:14 MST
Identified
We are continuing to monitor the AWS situation and will update as we know more. AWS health may be monitored directly at https://status.aws.amazon.com/
Posted Dec 07, 2021 - 10:22 MST
Update
We are still monitoring the AWS issues in US-EAST-1 and there is no further update on their progress. Accounts enabled with TOTP can choose that and successfully login to the user console. We will report back as soon as we have an update, or in 20 minutes.
Posted Dec 07, 2021 - 09:57 MST
Update
The MFA / user console issue appears to be related to the current AWS issues in US-EAST-1:

"AWS: We are experiencing API and console issues in the US-EAST-1 Region. We have identified root cause and we are actively working towards recovery. This issue is affecting the global console landing page, which is also hosted in US-EAST-1"

We are closely monitoring and still working this issue as a high priority. We will report back as soon as we have an update, or in 20 minutes
Posted Dec 07, 2021 - 09:38 MST
Investigating
We are currently investigating an issue with timeouts using JumpCloud Push with the user console. We will report back as soon as we have an update, or in 20 minutes. We apologize for any inconvenience this may cause.
Posted Dec 07, 2021 - 09:23 MST
This incident affected: User Console.