Degraded Agent Service
Incident Report for JumpCloud
Postmortem

JumpCloud Incident Report

Date: 2022-08-12

Date of Incident: 2022-08-10

Description: RCA for Agent Registration Degradation

Summary:

At approximately 15:00 MDT on 2022-08-10, some JumpCloud customers experienced issues with successfully registering systems.  When attempting to install new Agents on devices, they were returned a “Could not register with JumpCloud” message.  This lasted until approximately 17:00 MDT on 2022-08-10.

Root Cause:

The mechanism JumpCloud uses to programmatically render configuration files became degraded and failed to notify two of our Agent HAProxy servers of necessary changes after the completion of a schedule deploy to that service layer.  Customers attached to these two instances experienced degraded service registering Agents. ‌

Corrective Actions / Risk Mitigation:

  • On-going work to remove persistence from HAProxy - In Progress
  • Increased alerting on this service layer - Target 08/2022
  • Investigate configuration order for config management - Target 08/2022
Posted Aug 15, 2022 - 07:56 MDT

Resolved
This incident is now considered resolved. JumpCloud Agent installations and Agent connectivity should be fully functional.
Posted Aug 10, 2022 - 17:50 MDT
Monitoring
The issue has been identified and a fix has been implemented. We will continue to monitor JumpCloud Agent performance.
Posted Aug 10, 2022 - 17:08 MDT
Investigating
We're currently investigating reports of degraded performance or intermittent connection issues with JumpCloud's Agent for systems service. This may delay agent actions, user assignments to devices, and new device enrollments.

We are investigating the cause of the issues currently, and will update the status event once resolved.
Posted Aug 10, 2022 - 16:48 MDT
This incident affected: Agent.