Increased error rates in Multi-Tenant Portal
Incident Report for JumpCloud
Resolved
This incident has been resolved.
Posted Mar 02, 2023 - 17:20 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2023 - 17:13 MST
Update
We are continuing to work on a fix for this issue.
Posted Mar 02, 2023 - 16:58 MST
Identified
We've identified the issue and are implementing a fix.
Posted Mar 02, 2023 - 16:40 MST
Investigating
We are currently investigating an issue with increased error rates for MTP including:

Account Manager Calendar (API endpoints)
Provider Invoices
Organization Invoices
Organization Cases
Organization Payment Details
ConnectWise Integrations
AutoTask Integrations

We will update this issue as soon as we have more information.
Posted Mar 02, 2023 - 16:34 MST
This incident affected: Multi-Tenant Portal (MTP) and Payment and Billing.