LDAP-as-a-Service Availability
Incident Report for JumpCloud
Postmortem

JumpCloud Incident Report

Date: 2022-05-23

Date of Incident: 2022-05-18

Description: RCA for JumpCloud LDAP-as-a-Service Interruption

Summary:

At approximately 09:15 MDT on 2022-05-18, some JumpCloud customers experienced the inability to access JumpCloud’s LDAP-as-a-Service.  This loss of access lasted until approximately 09:30 MDT on 2022-05-18.

Root Cause:

The incident was caused by a code conflict with a zone apex record during a DNS change. This conflict was missed in our testing as that development environment lacked the correct resource to match the condition of this particular failure.

Corrective Actions / Risk Mitigation:

Deployment of this change has been placed on hold until both alerting is added, and the development environment condition is fixed.

  1. Immediate rollback of the change - DONE
  2. Add alerting at the DNS / Proxy layer for LDAP - Target 05/2022
  3. Add missing condition to match the development environment - Target 05/2022
  4. Process requiring a published maintenance window for these types of changes - DONE
Posted May 23, 2022 - 17:32 MDT

Resolved
This incident has been resolved.
Posted May 18, 2022 - 09:53 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2022 - 09:49 MDT
Investigating
We are currently investigating possible timeouts, or failures to authenticate using LDAP. We will report back as soon as we have an update. We apologize for any inconvenience this may cause.
Posted May 18, 2022 - 09:42 MDT
This incident affected: LDAP.