Premium Support Phone Service Outage
Incident Report for JumpCloud
Resolved
This incident has been resolved.
Posted Jan 05, 2023 - 06:34 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 05, 2023 - 05:47 MST
Investigating
We've identified an ongoing issue with the phone service used for JumpCloud Premium Support. At this time customers are not able to complete calls to the JumpCloud Customer Support line. We are working with our vendor to resolve this issue as quickly as possible.
Posted Jan 05, 2023 - 05:07 MST
This incident affected: Premium Support Phone Service.