Console Availability
Incident Report for JumpCloud
Postmortem

JumpCloud Incident Report

Date: 2022-05-02

Date of Incident: 2022-04-27

Description: RCA for JumpCloud Console Service Interruption

Summary:

Approximately 15:30 MDT on 2022-04-27, some JumpCloud customers experienced the inability to access the User or Admin console(s).  This loss of access lasted until approximately 15:50 MDT on 2022-04-27.

Root Cause:

The incident was caused by an order of operations problem where the deploy sequence was incorrect for this code branch.  This in turn caused a configuration variable to be deployed without the correct dependencies.  Additionally, a critical circuit breaker to stop the deployment when missing these dependencies failed due to a bad check in its procedure.

Corrective Actions / Risk Mitigation:

Deploys of this code branch have been stopped until the circuit breaker is fixed

  1. Immediate action to push the correct variable for this deploy - DONE
  2. Fix the circuit breaker for this deploy - DONE
  3. Add additional dependency checks to automated testing - Target 2022.05.11
Posted May 02, 2022 - 12:16 MDT

Resolved
This incident has been resolved.
Posted Apr 27, 2022 - 16:18 MDT
Monitoring
We have identified the cause of this interruption, administered a fix and are monitoring the results.
Posted Apr 27, 2022 - 16:00 MDT
Update
We are continuing to investigate this issue.
Posted Apr 27, 2022 - 15:55 MDT
Investigating
We are currently investigating possible timeouts or failures to load the JumpCloud User Console. We will report back as soon as we have an update. We apologize for any inconvenience this may cause.
Posted Apr 27, 2022 - 15:55 MDT
This incident affected: Admin Console and User Console.