Activation email links return incorrect error code that the email has already been used or has expired
Incident Report for JumpCloud
Resolved
This issue has been resolved.
Posted 2 months ago. Aug 08, 2019 - 13:51 MDT
Identified
This issue has been identified and a fix is being tested.
Posted 2 months ago. Aug 08, 2019 - 08:49 MDT
This incident affected: G Suite Integration and Office 365 Integration.