Admin Portal Performance

Incident Report for JumpCloud

Resolved

The issue is now marked as resolved.
Posted Oct 07, 2025 - 05:23 MDT

Monitoring

Our investigation uncovered intermittent latencies at several end-points which caused slow response times at the Admin portal for a few customers.
Out of an abundance of caution, we have rolled back a recent update and will continue monitoring.
Posted Oct 07, 2025 - 05:08 MDT

Investigating

We are investigating slow performance with the Admin Portal. We will update within an hour.
Posted Oct 07, 2025 - 03:32 MDT
This incident affected: Admin Console (Admin Console).