Degraded SAML SSO Service
Incident Report for JumpCloud
Postmortem

JumpCloud Incident Report

Date: 2023-03-07

Date of Incident: 2023-02-16

Description: RCA for JumpCloud SSO redirect failures with M365

Summary:

JumpCloud customers encountered a blank screen when attempting to access M365 via SSO.

Root Cause:

The incident was caused by a change to a library within the code for the login flow for that part of the UI.  That library change is not supported on Edge Webview which is used in the redirect for O365, causing the blank screen on redirect.

Corrective Actions / Risk Mitigation:

  • Fix the library function not supported by Edge Webview - Done
  • Update Login functional tests to cover legacy Edge - Done
  • Update Login UI documentation to specify Edge compatibility - Done
  • Add additional metrics and alerting  to surface these errors - Target 2023.03.15
Posted Mar 07, 2023 - 17:07 MST

Resolved
This incident has been resolved.
Posted Feb 16, 2023 - 04:29 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 16, 2023 - 04:04 MST
Investigating
We are currently investigating reports of degraded service with SAML SSO applications. Initial reports indicate that applications which are using a redirect from local desktop applications such as 0365, Fortinet, or OpenVPN may be impacted.
Posted Feb 16, 2023 - 02:15 MST
This incident affected: SSO.