3rd Party Provider Operational Issues

Incident Report for JumpCloud

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 15:46 MDT

Monitoring

We've seen an increase in recovery and are monitoring
Posted Oct 20, 2025 - 11:43 MDT

Identified

We are monitoring our services and continue to work with our provider to restore full functionality.
Posted Oct 20, 2025 - 09:50 MDT

Investigating

Due to an issue with our Cloud Provider, JumpCloud is experiencing intermittent issues with our PAM service and some Support tools which may affect case creation. We are investigating this with our provider and will update this incident as we know more.
Posted Oct 20, 2025 - 09:44 MDT
This incident affected: PAM (JumpCloud's VaultOne) (PAM (JumpCloud's VaultOne)) and Support Services (Premium Chat Support).