Issue Creating Admin Accounts.

Incident Report for JumpCloud

Resolved

This incident has been resolved
Posted Aug 05, 2025 - 04:14 MDT

Update

We are continuing to monitor for any further issues.
Posted Aug 05, 2025 - 04:00 MDT

Monitoring

A fix has been implemented and we are monitoring the results. Admins should now be able to create new admin accounts and modify admin roles.
Posted Aug 05, 2025 - 03:59 MDT

Identified

We have identified the issue and are working on a fix for this issue. We will provide a further an update within 1 hour.
Posted Aug 05, 2025 - 03:24 MDT

Investigating

We are currently investigating an issue with adding Admin accounts or modifying admin roles. Our team is actively working on this and will supply an update within 1 hour.
Posted Aug 05, 2025 - 03:23 MDT
This incident affected: Admin Console.