Agent polling degradation

Incident Report for JumpCloud

Resolved

This incident has been resolved.
Posted Mar 30, 2022 - 19:45 MDT

Update

We have fixed the majority of this issue, but there may still be a very small subset of devices that are not checking in, or polling our backend systems correctly. If you find a device that appears to be in this state, please check the jc.agent.conf:

macOS | Linux:
/opt/jc/jcagent.conf

Windows:
C:\Program Files\JumpCloud\Plugins\Contrib\jcagent.conf

In that file, you can change the "agentServerGoPort" from 8339 to 443 (if it is not already at 443). You should then save that file and restart the JumpCloud Agent. If you still have trouble, or need additional help please open a case with our Support team.
Posted Mar 30, 2022 - 13:19 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2022 - 11:32 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 30, 2022 - 10:46 MDT

Investigating

We are currently investigating reports of a possible JumpCloud Devices Agent issue not polling backend systems correctly. We will report back as soon as we have an update, or in 30 minutes. We apologize for any disruption this may cause.
Posted Mar 30, 2022 - 10:21 MDT
This incident affected: Agent.